ライブラリ

manecoでは各プログラム言語向けのライブラリを提供しています。
加盟店様サーバにライブラリをインストールすることにより、効率的にmanecoを導入することができます。

PHP

動作環境

PHP5.4以上
OpenSSL0.9.8o以上
Composerのインストールが必要になります。

導入方法

加盟店様サーバのcomposer.jsonに

{
    "require": {
        "maneco/maneco": "1.0.0"
    }
}

と記述することにより、composerを利用してライブラリをインストールすることができます。

ソースファイルはGithubよりダウンロードすることができます。
https://github.com/paygent/maneco-php

依存しているライブラリを含めたソースファイル群のzipファイルをダウンロードできます。
maneco_php_1.0.0.zip

Java

動作環境

Java1.6.0_22以上
Mavenのインストールが必要になります。

導入方法

加盟店様サーバのpom.xmlに

<dependency>
    <groupId>jp.co.paygent</groupId>
    <artifactId>maneco</artifactId>
    <version>1.0.0</version>
</dependency>

と記述することにより、ライブラリをインストールすることができます。

ソースファイルはGithubよりダウンロードすることができます。
https://github.com/paygent/maneco-java